summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2006-07-25 19:14:21 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2006-07-25 19:14:21 +0000
commitd71c093565ef17c099e2b3d83ad2c679f1c3e17c (patch)
tree6cfd64f1b669400d9de11c14d962de08ef271b1a /lib/make/configure.in
parent584742382c60ed6718109b4c92ba03dbd8c5f70e (diff)
Cactus only enables support for CCTK_REALx if both C and Fortran
support this type. This does not make sense if there is no Fortran compiler. Disable the check whether real*n is supported in Fortran when there is no Fortran compiler. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4354 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 848cdc78..9af917fb 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -816,17 +816,17 @@ if test "x$DISABLE_REAL16" != 'xyes' -a "x$DISABLE_REAL16" != 'xno' -a "x$DISABL
AC_ERROR([Didn't recognise setting of DISABLE_REAL16=\"$DISABLE_REAL16\"; should be either \"yes\" or \"no\" or \"\" (empty)])
fi
-if test -n "$CCTK_REAL16" -a "x$cctk_cv_have_fortran_real16" = 'xyes' -a "x$cctk_cv_have_fortran_complex32" = 'xyes' -a "x$DISABLE_REAL16" != 'xyes' ; then
+if test -n "$CCTK_REAL16" -a \( "x$F77" = 'xnone' -o \( "x$cctk_cv_have_fortran_real16" = 'xyes' -a "x$cctk_cv_have_fortran_complex32" = 'xyes' \) \) -a "x$DISABLE_REAL16" != 'xyes' ; then
AC_DEFINE_UNQUOTED(CCTK_REAL16, $CCTK_REAL16)
AC_DEFINE(HAVE_CCTK_REAL16)
fi
-if test -n "$CCTK_REAL8" -a "x$cctk_cv_have_fortran_real8" -a "x$cctk_cv_have_fortran_complex16" = 'xyes' ; then
+if test -n "$CCTK_REAL8" -a \( "x$F77" = 'xnone' -o \( "x$cctk_cv_have_fortran_real8" -a "x$cctk_cv_have_fortran_complex16" = 'xyes' \) \); then
AC_DEFINE_UNQUOTED(CCTK_REAL8, $CCTK_REAL8)
AC_DEFINE(HAVE_CCTK_REAL8)
fi
-if test -n "$CCTK_REAL4" -a "x$cctk_cv_have_fortran_real4" = 'xyes' -a "x$cctk_cv_have_fortran_complex8" = 'xyes' ; then
+if test -n "$CCTK_REAL4" -a \( "x$F77" = 'xnone' -o \( "x$cctk_cv_have_fortran_real4" = 'xyes' -a "x$cctk_cv_have_fortran_complex8" = 'xyes' \) \); then
AC_DEFINE_UNQUOTED(CCTK_REAL4, $CCTK_REAL4)
AC_DEFINE(HAVE_CCTK_REAL4)
fi