summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorjthorn <jthorn@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-02-10 14:47:28 +0000
committerjthorn <jthorn@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-02-10 14:47:28 +0000
commitce7a558df5d4f4443f8e364b0eb5c50c9e1177c5 (patch)
treef5f3bb3c6c07cf8726fc8c4d47d4bd4be2386456 /lib/make/configure.in
parent50d91252462a1c4ea29ed598cc3597166cdc6c05 (diff)
bugfix in previous commit -- hopefully we now handle all possible cases
of OPTIMISE=something and OPTIMIZE=something-else correctly git-svn-id: http://svn.cactuscode.org/flesh/trunk@3987 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 949c0e65..8299f1f8 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -45,7 +45,7 @@ if test -n "$OPTIMISE" ; then
OPTIMISE=`echo $OPTIMISE | tr '[:upper:]' '[:lower:]'`
OPTIMIZE=`echo $OPTIMIZE | tr '[:upper:]' '[:lower:]'`
changequote([, ])
- if test "$OPTIMISE" != "$OPTIMIZE" ; then
+ if test -n "$OPTIMIZE" -a "$OPTIMISE" != "$OPTIMIZE" ; then
AC_ERROR(OPTIMISE=\"$OPTIMISE\" is inconsistent with OPTIMIZE=\"$OPTIMIZE\"!)
fi
if test "$OPTIMISE" != 'yes' -a "$OPTIMISE" != 'no' ; then