summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorallen <allen@17b73243-c579-4c4c-a9d2-2d5706c11dac>2001-03-10 15:23:42 +0000
committerallen <allen@17b73243-c579-4c4c-a9d2-2d5706c11dac>2001-03-10 15:23:42 +0000
commitc7b4df6f78c0f9673fd7e67f6ea639f3c2ff9679 (patch)
treecc8b0457da933c1cdd11012abfc01c3f10dc21d9 /lib/make/configure.in
parent416d2129ea3832a988e91ba61542f423525f6b88 (diff)
Fix for Cactus/547 and more.
Hopefully configuring with and without the different fortran compilers now works. You can (hopefully) say F90=none and/or F77=none and get no complaints about unknown compilers and get all the underscores sorted out. In doing this I removed for now the F90_NOT_SET that I had put in before so that you get a semi decent line if you try and compile a fortran file with no fortran compiler since it was stretching my logic capabilities. Now you will get a less decent line, but it will still say "none" for the compiler rather than saying nothing. I'll try and remember to put it back. I'm think we can easily add the ability to have different F77 and F90 compilers as well, so long as they have the same underscore behaviour, but probably noone needs that. git-svn-id: http://svn.cactuscode.org/flesh/trunk@2074 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 7e198539..7e5a90d1 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -206,8 +206,12 @@ EOF
# Deal with the Fortran compiler issues.
# If there's a Fortran 90 compiler use that for all the Fortran.
if test "x$F90" != "x" ; then
- F77=$F90
- : {F77FLAGS=$F90FLAGS} ;
+ if test "x$F90" != "xnone" ; then
+ if test "x$F77" != "xnone" ; then
+ F77=$F90
+ : {F77FLAGS=$F90FLAGS} ;
+ fi
+ fi
fi
# The known architecture stuff has probably set the LIBS variable
@@ -1080,16 +1084,16 @@ AC_DEFINE_UNQUOTED(CCTK_L2_CACHE_SIZE, $L2_CACHE_SIZE)
dnl Run any other scripts necessary
-AC_OUTPUT_COMMANDS(,$PERL -s $PERL_CONFIGURE_SCRIPT -compiler="$F77" -opts="$F77FLAGS" .)
+AC_OUTPUT_COMMANDS(,$PERL -s $PERL_CONFIGURE_SCRIPT -compiler_f77="$F77" -opts_f77="$F77FLAGS" -compiler_f90="$F90" -opts_f90="$F90FLAGS" .)
# Set default Fortran compilers
AC_SUBST(F90)
if test -z "$F90" ; then
- F90="F90_NOT_SET"
+ F90="none"
fi
AC_SUBST(F77)
if test -z "$F77" ; then
- F77="F77_NOT_SET"
+ F77="none"
fi
dnl Output everything