summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2006-07-25 20:07:35 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2006-07-25 20:07:35 +0000
commit914bb82a07bd9488c03998431406315a608ad52a (patch)
treea940dd7b2f63ffa25c704908ccd777d264fb7b74 /lib/make/configure.in
parentd37fe298527cf86cfec4be254a66c3338567abed (diff)
Set the F77 profile flags as well when setting the F77 flags. This
somehow got lost in the previous change. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4356 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 7fc96872..5f461406 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -339,12 +339,13 @@ AC_SUBST(F90_PROFILE_FLAGS)
# Deal with the Fortran compiler issues.
# If there's a Fortran 90 compiler use that for all the Fortran.
-if test "x$F90" != "x" -a "x$F90" != "xnone" -a "x$KNOWN_F77" = "x" ; then
+if test "x$F90" != "x" -a "x$F90" != "xnone" -a "x$F77" = "x" ; then
F77=$F90
F77FLAGS=$F90FLAGS
+ F77_WARN_FLAGS=$F90_WARN_FLAGS
F77_DEBUG_FLAGS=$F90_DEBUG_FLAGS
F77_OPTIMISE_FLAGS=$F90_OPTIMISE_FLAGS
- F77_WARN_FLAGS=$F90_WARN_FLAGS
+ F77_PROFILE_FLAGS=$F90_PROFILE_FLAGS
fi
# The known architecture stuff has probably set the LIBS variable