summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authortradke <tradke@17b73243-c579-4c4c-a9d2-2d5706c11dac>2001-06-18 16:15:33 +0000
committertradke <tradke@17b73243-c579-4c4c-a9d2-2d5706c11dac>2001-06-18 16:15:33 +0000
commit75f997988ed64a8f8e5a24482642eeb556a2e853 (patch)
tree349cfbf94d6c40325f3e5e88f47c2cb3eff971bf /lib/make/configure.in
parent0d3694da361c1084f95d530c3ed5a90562f67f9e (diff)
Added some more options to C_WARN_FLAGS and CXX_WARN_FLAGS resp.
if the C/C++ compiler is gcc/[cg]++. Since this is set by configure now it will be used for all architectures (not just Linux). git-svn-id: http://svn.cactuscode.org/flesh/trunk@2236 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 9c962bd0..d796d163 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -894,7 +894,7 @@ AC_SUBST(C_WARN_FLAGS)
if test -z "$C_WARN_FLAGS" ; then
case "$CC" in
gcc)
- C_WARN_FLAGS="-Wall"
+ C_WARN_FLAGS="-Wall -W -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Winline"
;;
*)
# Not sure what should be a reasonable default.
@@ -907,8 +907,8 @@ AC_SUBST(CXX_WARN_FLAGS)
if test -z "$CXX_WARN_FLAGS" ; then
case "$CXX" in
- g++)
- CXX_WARN_FLAGS="-Wall"
+ c++ | g++)
+ CXX_WARN_FLAGS="\$(C_WARN_FLAGS) -Woverloaded-virtual"
;;
*)
# Not sure what should be a reasonable default.