summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorgoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-09-01 00:13:15 +0000
committergoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-09-01 00:13:15 +0000
commit52cbd118d73ee54579ad9d6ef8d975cc2fd8e052 (patch)
tree797e199ffc30ed35891c7ccf356ae6e94f957247 /lib/make/configure.in
parent38afc5bd5081cd024c7cc25ee882b138927548c6 (diff)
Can now pass CXX=none to the configure line. The checks for CXX are then
bypassed in the configure script, and flesh.cc is compiled as C rather than C++. Tom git-svn-id: http://svn.cactuscode.org/flesh/trunk@1807 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in40
1 files changed, 25 insertions, 15 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 74dda343..b4677d0f 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -63,12 +63,14 @@ fi
CCTK_PROG_CC_WORKS
AC_PROG_CC_GNU
-if test -z "$CXX" ; then
-AC_CHECK_PROGS(CXX, c++ g++ gcc CC cxx cc++ cl xlC)
-fi
+if test "x$CXX" != "xnone" ; then
+ if test -z "$CXX" ; then
+ AC_CHECK_PROGS(CXX, c++ g++ gcc CC cxx cc++ cl xlC)
+ fi
-CCTK_PROG_CXX_WORKS
-AC_PROG_CXX_GNU
+ CCTK_PROG_CXX_WORKS
+ AC_PROG_CXX_GNU
+fi
if test -z "$RANLIB" ; then
AC_PROG_RANLIB
@@ -104,11 +106,17 @@ if test -z "$SHELL" ; then
AC_CHECK_PROGS(SHELL, sh bash)
fi
-if test -z "$LD" ; then
AC_SUBST(LD)
-LD=$CXX
+
+if test -z "$LD" ; then
+ if test "x$CXX" != "xnone" ; then
+ LD=$CXX
+ else
+ LD=$CC
+ fi
fi
+
# Restore the values we saved earlier
if test -n "$KNOWN_LIBS" ; then
@@ -382,16 +390,18 @@ CCTK_CHECK_SOCK_LENGTH_TYPE
# C++ STL stuff
-AC_LANG_SAVE
-AC_LANG_CPLUSPLUS
-CCTK_CHECK_HEADERS(vector vector.h)
-AC_LANG_RESTORE
+if test "x$CXX" != "xnone" ; then
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ CCTK_CHECK_HEADERS(vector vector.h)
+ AC_LANG_RESTORE
-AC_LANG_SAVE
-AC_LANG_CPLUSPLUS
-AC_TRY_COMPILE(, bool foo;,
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ AC_TRY_COMPILE(, bool foo;,
AC_DEFINE(HAVE_BOOL))
-AC_LANG_RESTORE
+ AC_LANG_RESTORE
+fi
dnl Misc stuff