summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authortradke <tradke@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-11-04 18:58:47 +0000
committertradke <tradke@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-11-04 18:58:47 +0000
commit448cfb0df05c875f98ed96306bef6ea3ad175134 (patch)
treeeb922b9bd709c6593ab11928a29e65f35f3206c3 /lib/make/configure.in
parent1682433ce1b05b6ce6f94652fde6ce26089cc83c (diff)
Search for gethostbyname(3) also in libnls.so.
Now this function gets detected properly on Solaris machines. git-svn-id: http://svn.cactuscode.org/flesh/trunk@1883 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in31
1 files changed, 23 insertions, 8 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 44cf31cb..f8d364e3 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -358,12 +358,30 @@ AC_SUBST(F77FLAGS)
dnl Checks for library functions.
+# Do we have mkdir(2) ?
CCTK_CHECK_FUNCS(mkdir)
-CCTK_CHECK_FUNCS(scandir, ,
-[SAVED_LIBDIRS="$LIBDIRS"
-LIBDIRS="$LIBDIRS /usr/ucblib"
-CCTK_CHECK_LIB(ucb, scandir, AC_DEFINE(HAVE_SCANDIR), LIBDIRS="$SAVED_LIBDIRS")
-])
+
+# Do we have scandir(3) ?
+# For Solaris we should search in /usr/ucblib/libucb.a
+CCTK_CHECK_FUNCS(scandir,
+ ,
+ [SAVED_LIBDIRS="$LIBDIRS"
+ LIBDIRS="$LIBDIRS /usr/ucblib"
+ CCTK_CHECK_LIB(ucb,
+ scandir,
+ AC_DEFINE(HAVE_SCANDIR),
+ LIBDIRS="$SAVED_LIBDIRS")
+ ]
+)
+
+# Do we have gethostbyname(3) ?
+# For Solaris we should search in libnsl.so
+CCTK_CHECK_FUNCS(gethostbyname,
+ ,
+ CCTK_CHECK_LIB(nsl,
+ gethostbyname,
+ AC_DEFINE(HAVE_GETHOSTBYNAME))
+)
# Check if we have mode_t available
AC_MSG_CHECKING([if mode_t is defined])
@@ -489,9 +507,6 @@ else
AC_MSG_RESULT(no)
fi
-# Do we have gethostbyname
-CCTK_CHECK_FUNCS(gethostbyname)
-
# C++ STL stuff
if test "x$CXX" != "xnone" ; then