summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorrhaas <rhaas@17b73243-c579-4c4c-a9d2-2d5706c11dac>2013-02-08 18:45:49 +0000
committerrhaas <rhaas@17b73243-c579-4c4c-a9d2-2d5706c11dac>2013-02-08 18:45:49 +0000
commit43b44fdf6a8524dda6afe9bac0342eeba5ac5835 (patch)
tree818ea4a537bc93e3e7e7ef9b6a6019982f519d5e /lib/make/configure.in
parentd8d08a3a12b5c3810de7eaeb23878b897779debd (diff)
correctly quote regular expressions in aclocal.m4
m4 uses square brackets as quotation characters and removes one set of them per argument call. This affects regular expressions that contain character ranges. This in turn affect some HAVE_XXX macros where XXX contains invalid characters eg. XXX=math.h . The attached patch adds an extra level of [] around where the result is passed to a function. Also it seems as if the system provided AC_CHECK_FUNCS does not properly quote its third argument when passing it to AC_CHECK_FUNC. Hence I add an extra round of [] whenever it is used. This is a mess. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4953 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index c8351ee4..dbbf846b 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -951,7 +951,7 @@ AC_LANG_RESTORE
dnl Do we have dladdr(3) and the structure it uses?
CCTK_CHECK_MEMBER(Dl_info, dli_sname,
- CCTK_CHECK_FUNCS(dladdr, , CCTK_CHECK_LIB_FUNC(dl, dladdr)),
+ [CCTK_CHECK_FUNCS(dladdr, , [CCTK_CHECK_LIB_FUNC(dl, dladdr)])],
,
[#define _GNU_SOURCE 1
#include <dlfcn.h>] )
@@ -964,7 +964,7 @@ dnl Do we have backtrace_symbols(3)
CCTK_CHECK_FUNCS(backtrace_symbols, , )
dnl Do we have crypt(3)
-CCTK_CHECK_FUNCS(crypt, , CCTK_CHECK_LIB_FUNC(crypt, crypt))
+CCTK_CHECK_FUNCS(crypt, , [CCTK_CHECK_LIB_FUNC(crypt, crypt)])
dnl Do we have certain math functions or macros?
CCTK_CHECK_HEADER_LIB_FUNC(math.h, m, finite, (1.0))
@@ -977,7 +977,7 @@ CCTK_CHECK_HEADER_LIB_FUNC(math.h, m, isnormal, (1.0))
CCTK_CHECK_HEADER_LIB_FUNC(math.h, m, signbit, (1.0))
dnl Do we have mkstemp(3)
-CCTK_CHECK_FUNCS(mkstemp, , CCTK_CHECK_LIB_FUNC(c, mkstemp))
+CCTK_CHECK_FUNCS(mkstemp, , [CCTK_CHECK_LIB_FUNC(c, mkstemp)])
dnl Do we have va_copy(3)
AC_MSG_CHECKING([for va_copy])