summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2007-05-03 03:22:15 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2007-05-03 03:22:15 +0000
commit37a2773bd47aa054ca37e5a9851db5daed5332ca (patch)
treecec28f25d0fa2e074fe63439fb9bac4e72b2afe7 /lib/make/configure.in
parent934ebfc5904fec1cd74181849e0c1964dcb60d07 (diff)
Use fewer warning flags for C and C++ compilers by default.
git-svn-id: http://svn.cactuscode.org/flesh/trunk@4419 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in18
1 files changed, 11 insertions, 7 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 6fab4413..7d00a66b 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -255,28 +255,32 @@ AC_SUBST(WARN_MODE)
# Set the warning flags if they've not been set by now
# (using GNU compiler warning flags as a reasonable default)
AC_SUBST(C_WARN_FLAGS)
-if test -z "$C_WARN_FLAGS" -a "$CC" = 'gcc' ; then
- C_WARN_FLAGS='-Wall -W -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Winline'
+if test "$CC" = 'gcc' ; then
+ : ${C_WARN_FLAGS='-Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wbad-function-cast -Wsign-compare'}
else
: ${C_WARN_FLAGS=''}
fi
AC_SUBST(CXX_WARN_FLAGS)
-if test -z "$CXX_WARN_FLAGS" -a \( "$CXX" = 'c++' -o "$CXX" = 'g++' \) ; then
- CXX_WARN_FLAGS='-Wall -W -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Winline -Woverloaded-virtual'
+if test "$CXX" = 'c++' -o "$CXX" = 'g++' ; then
+ : ${CXX_WARN_FLAGS='-Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Woverloaded-virtual'}
else
: ${CXX_WARN_FLAGS=''}
fi
AC_SUBST(F77_WARN_FLAGS)
-if test -z "$F77_WARN_FLAGS" -a "$F77" = 'g77' ; then
- F77_WARN_FLAGS='-Wall'
+if test "$F77" = 'g77' ; then
+ : ${F77_WARN_FLAGS='-Wall'}
else
: ${F77_WARN_FLAGS=''}
fi
AC_SUBST(F90_WARN_FLAGS)
-: ${F90_WARN_FLAGS=''}
+if test "$F90" = 'gfortran' ; then
+ : ${F90_WARN_FLAGS='-Wall -Wshadow -Wsurprising'}
+else
+ : ${F90_WARN_FLAGS=''}
+fi
AC_SUBST(DEBUG_MODE)