summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorgoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-07-18 15:02:56 +0000
committergoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-07-18 15:02:56 +0000
commit2cf31e125b0d67a53ed6d7dd35aac87173d645d7 (patch)
treeb602d4c69593a1be12027503100bc2bef7bec639 /lib/make/configure.in
parent2e0865147ac4379c3ec4d3f477cfd599fe41703f (diff)
Detect if the C++ compiler defines bool, if not, do a typedef.
This is needed, for example, for xlC. Tom git-svn-id: http://svn.cactuscode.org/flesh/trunk@1758 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 6bf957e5..ae36ce85 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -384,6 +384,12 @@ AC_LANG_CPLUSPLUS
CCTK_CHECK_HEADERS(vector vector.h)
AC_LANG_RESTORE
+AC_LANG_SAVE
+AC_LANG_CPLUSPLUS
+AC_TRY_COMPILE(, bool foo;,
+AC_DEFINE(HAVE_BOOL))
+AC_LANG_RESTORE
+
dnl Misc stuff
dnl Do we need to build the GNU getopt and regex stuff ?