summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2004-01-19 14:50:51 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2004-01-19 14:50:51 +0000
commit1fd1c9e06006a4a96e97afca588dd73e02bdd314 (patch)
treeab011183c22c83cdaa962b29bf3a4cee076d0da5 /lib/make/configure.in
parent6b159579c63e41bcc1ed9e34b91efe753886060c (diff)
Make error messages and debug information point to the real source
file instead of the preprocessed file. The options C_LINE_DIRECTIVES and F_LINE_DIRECTIVES control this behaviour. git-svn-id: http://svn.cactuscode.org/flesh/trunk@3527 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index bd2dcee3..118ca378 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -669,6 +669,31 @@ esac
AC_DEFINE_UNQUOTED(CCTK_FCALL, $CCTK_FCALL)
+# Decide whether the preprocessed C and Fortran files should contain
+# C preprocessor line directives to point to the original source file
+
+AC_DEFINE_UNQUOTED(C_LINE_DIRECTIVES, "$C_LINE_DIRECTIVES")
+AC_DEFINE_UNQUOTED(F_LINE_DIRECTIVES, "$F_LINE_DIRECTIVES")
+
+AC_SUBST(C_LINE_DIRECTIVES)
+AC_SUBST(F_LINE_DIRECTIVES)
+
+if test -n "$C_LINE_DIRECTIVES" ; then
+ if test "$C_LINE_DIRECTIVES" != "yes" -a "$C_LINE_DIRECTIVES" != "no" ; then
+ AC_ERROR(Didn't recognize setting of C_LINE_DIRECTIVES=\"$C_LINE_DIRECTIVES\" (should be either \"yes\" or \"no\"))
+ fi
+else
+ C_LINE_DIRECTIVES='yes'
+fi
+if test -n "$F_LINE_DIRECTIVES" ; then
+ if test "$F_LINE_DIRECTIVES" != "yes" -a "$F_LINE_DIRECTIVES" != "no" ; then
+ AC_ERROR(Didn't recognize setting of F_LINE_DIRECTIVES=\"$F_LINE_DIRECTIVES\" (should be either \"yes\" or \"no\"))
+ fi
+else
+ F_LINE_DIRECTIVES='yes'
+fi
+
+
# Define how to make a directory in the config.h file
AC_DEFINE_UNQUOTED(MKDIR, "$MKDIR")