summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2007-02-17 22:51:00 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2007-02-17 22:51:00 +0000
commit0dec0e4302e3efd9e6d330f546adbca594250ecf (patch)
tree9122b80f8753cf4a055417067c137f3223069b1f /lib/make/configure.in
parent20e50d8110b0e1d1a375b3d56ebd75dee79cf347 (diff)
Prefer bash over sh. sh on AIX has severe limitations and cannot
handle long argument lists, which prevents calling ar or ld when there are many thorns. Add a comment describing why setting SHELL when configuring does not work. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4409 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 5f461406..6fab4413 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -194,8 +194,10 @@ if test -z "$MKDIR" ; then
AC_CHECK_PROGS(MKDIR, mkdir)
fi
-if test -z "$SHELL" ; then
- AC_CHECK_PROGS(SHELL, sh bash)
+# autoconf sets $SHELL unconditionally; we can only overwrite it here.
+# The user has to set $CONFIG_SHELL to override this.
+if test -z "$CONFIG_SHELL" ; then
+ AC_CHECK_PROGS(SHELL, bash sh)
fi
AC_SUBST(LD)