summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorgoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-10-31 21:59:19 +0000
committergoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-10-31 21:59:19 +0000
commit08abd0978a804f09eb66adcd24b5b1585c2a348d (patch)
treedd956dfe8754ea4fbb9c3b14c6e613ffb12a5547 /lib/make/configure.in
parentea5411a74408b6664efd2c7be9b000a11af69671 (diff)
Looking for __int64. This provides us with an 8 byte int under NT.
Tom git-svn-id: http://svn.cactuscode.org/flesh/trunk@1875 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 0567997c..e2202c97 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -466,6 +466,20 @@ else
AC_MSG_RESULT(no)
fi
+# Check if we have __int64
+AC_MSG_CHECKING([if __int64 is defined])
+AC_CACHE_VAL(cctk_cv_have___int64,
+[AC_TRY_COMPILE(,
+[__int64 foo; return 0], eval "cctk_cv_have___int64=yes",
+eval "cctk_cv_have___int64=no")
+])
+if test "$cctk_cv_have___int64" = "yes"; then
+ CCTK_INT8="__int64"
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
# Do we have gethostbyname
AC_CHECK_FUNCS(gethostbyname)