summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-09-26 00:13:36 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-09-26 00:13:36 +0000
commit06d94fb1dae1bedc506b432ccb1157d6aaa874d8 (patch)
treef424d9244ed0e99c56fdc2cd1c958bafbc343161 /lib/make/configure.in
parent41a5581e5979c6c7b50f545672a2969ba4eb973e (diff)
If the user has explicitly specified a setting for F77, then do not
override it. Override only settings that have been detected automatically. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4145 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 32a99507..8c39c6e8 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -133,6 +133,7 @@ if test -z "$F90" ; then
AC_CHECK_PROGS(F90, f90 pgf90 xlf90 ifort)
fi
+USER_F77="$F77"
if test -z "$F77" ; then
AC_CHECK_PROGS(F77, f77 pgf77 g77 f90 pgf90 xlf90 ifort)
fi
@@ -200,8 +201,9 @@ CCTK_WriteLine cctk_Archdefs.h '#endif /* _CCTK_ARCHDEFS_H_ */'
#########################################################################
# Deal with the Fortran compiler issues.
-# If there's a Fortran 90 compiler use that for all the Fortran.
-if test "x$F90" != 'x' -a "x$F90" != 'xnone' -a "x$F77" != 'xnone' ; then
+# If there's a Fortran 90 compiler, and if the user hasn't explicitly
+# specified a Fortran 77 compiler, use that for all the Fortran.
+if test "x$USER_F77" = 'x' -a "x$F90" != 'x' -a "x$F90" != 'xnone' -a "x$F77" != 'xnone' ; then
F77=$F90
: {F77FLAGS=$F90FLAGS}
fi