summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandre Flament <alex@al-f.net>2021-07-27 18:37:46 +0200
committerAlexandre Flament <alex@al-f.net>2021-07-30 14:40:09 +0200
commit4b43775c91a3c2ef415527edb4b3c041859453b4 (patch)
treead1290823e83664e16be560f7e5ae59c77a9efc7 /setup.py
parent24fcd7475a280e74105840b7b63fca3be4dbf397 (diff)
version based on the git repository
This commit remove the need to update the brand for GIT_URL and GIT_BRANCH: there are read from the git repository. It is possible to call python -m searx.version freeze to freeze the current version. Useful when the code is installed outside git (distro package, docker, etc...)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index b320524d..6a2f7c1f 100644
--- a/setup.py
+++ b/setup.py
@@ -4,10 +4,7 @@
from setuptools import setup
from setuptools import find_packages
-import os
-import sys
-
-from searx.version import VERSION_STRING
+from searx.version import VERSION_TAG, GIT_URL
from searx import get_setting
with open('README.rst', encoding='utf-8') as f:
@@ -21,12 +18,12 @@ with open('requirements-dev.txt') as f:
setup(
name='searx',
- version=VERSION_STRING,
+ version=VERSION_TAG,
description="A privacy-respecting, hackable metasearch engine",
long_description=long_description,
url=get_setting('brand.docs_url'),
project_urls={
- "Code": get_setting('brand.git_url'),
+ "Code": GIT_URL,
"Issue tracker": get_setting('brand.issue_url')
},
classifiers=[