summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarkus Heiser <markus.heiser@darmarIT.de>2020-08-08 18:01:04 +0000
committerGitHub <noreply@github.com>2020-08-08 20:01:04 +0200
commit3c45fb7a99c09166c36001d442312363b436b6ac (patch)
treecd381e3f717ef33ace5d148271b19c51abcfda0b /setup.py
parent623fb8706561451ac3680f5ca5e08e6b6e73bf95 (diff)
[fix] set encoding of README.rst explicit in setup.py (utf-8) (#2117)
## What does this PR do? When installing searx on a centos-7 image [1] an encoding exception is raised from setup.py:: command: /usr/local/searx/searx-pyenv/bin/python3 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/usr/local/searx/searx-src/setup.py'"'"'; __file__='"'"'/usr/local/searx/searx-src/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-pidntzkq cwd: /usr/local/searx/searx-src/ Complete output (7 lines): Traceback (most recent call last): File "<string>", line 1, in <module> File "/usr/local/searx/searx-src/setup.py", line 16, in <module> long_description = f.read() File "/usr/lib64/python3.6/encodings/ascii.py", line 26, in decode return codecs.ascii_decode(input, self.errors)[0] UnicodeDecodeError: 'ascii' codec can't decode byte 0xc9 in position 482: ordinal not in range(128) [1] https://uk.images.linuxcontainers.org/ ## Why is this change important? README.rst uses non ASCII characters _(pronunciation səːks.)_ ## How to test this PR locally? install searx on a centos-7 image from https://uk.images.linuxcontainers.org/
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 97a3270e..6a78f61b 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ sys.path.insert(0, './searx')
from version import VERSION_STRING
import brand
-with open('README.rst') as f:
+with open('README.rst', encoding='utf-8') as f:
long_description = f.read()
with open('requirements.txt') as f: