summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandre Flament <alex@al-f.net>2021-01-05 11:24:39 +0100
committerAlexandre Flament <alex@al-f.net>2021-01-12 11:47:17 +0100
commit3a9f513521d006a7939538cce368d7b799e32c30 (patch)
tree238da19ef56643af53b13ef24a330277ed53ae51 /setup.py
parent6e2872f43625aba71eba019e16f7fbd74743f590 (diff)
[enh] checker: background check
See settings.yml for the options SIGUSR1 signal starts the checker. The result is available at /stats/checker
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f89f1682..09a3021e 100644
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,8 @@ setup(
},
entry_points={
'console_scripts': [
- 'searx-run = searx.webapp:run'
+ 'searx-run = searx.webapp:run',
+ 'searx-checker = searx.search.checker.__main__:main'
]
},
package_data={