summaryrefslogtreecommitdiff
path: root/docs
Commit message (Collapse)AuthorAge
...
* Add a note about clang-format to the changelogskullY2019-08-30
|
* Merge point for 2019 Aug 30 Breaking ChangeskullY2019-08-30
|
* Fix the LUFA lib to use a submodule instead of just files (#6245)Drashna Jaelre2019-08-30
| | | | | | | | | | | | * Remove LUFA files * Update descriptions for newer version of LUFA * Create PR6245.md * Fix CDC(Serial) type errors * Fix missed merge conflict for AUDIO_DTYPE_CSInterface
* Update Atreus to current code conventions (#5849)Joel Challis2019-08-30
| | | | | | | | | | * Update atreus to current code conventions - add multi revision instead of defines * Remove config.h duplication from user keymaps * Add breaking change log * Add missing pragma once
* Migrate ACTION_BACKLIGHT_* to BL_* (#6299)fauxpark2019-08-30
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Branch point for 2019 Aug 30 Breaking Change * LUFA USB descriptor cleanup (#4871) * Fix indentation * Fix braces * Expand descriptor headers * Align descriptor elements * Nicer formatting * Tidy up preprocessor statements * Remove VERSION_BCD redefine - LUFA_VERSION_INTEGER is currently 0x170418 * Tidy up comments * Tweak ordering of HID report elements (no functional changes) * We don't need all of these newlines * Move default USB_MAX_POWER_CONSUMPTION closer to where it makes sense * Ask nicely * Add some more comments * Change indentation back to 4 spaces * Add changelog entry * Language Keymap extras backport from ZSA fork (#6198) * Swedish extra keymap refactor * Fix swedish $ sign definition (#81) * Fix br abnt2 keymap compilation error * Add PR changelog doc * Update PR6198.md * Enforce clang-format (#6293) * Enforce clang-format on commit for core files * forgot about tests * Migrate ACTION_LAYER_MOMENTARYs to MO() (#5176) * Migrate ACTION_LAYER_MOMENTARYs to MO() * Add changelog entry * Update docs/ChangeLog/20190830/PR5176.md Co-Authored-By: skullydazed <skullydazed@users.noreply.github.com> * Migrate ACTION_BACKLIGHT_* to BL_* * Add changelog * Update docs/ChangeLog/20190830/PR6299.md Co-Authored-By: skullydazed <skullydazed@users.noreply.github.com>
* Remove KC_DELT alias in favor of KC_DEL (#6327)Konstantin Đorđević2019-08-30
| | | | | | * Remove KC_DELT alias in favor of KC_DEL * Add changelog
* Migrate ACTION_LAYER_MOMENTARYs to MO() (#5176)fauxpark2019-08-30
| | | | | | | | | | * Migrate ACTION_LAYER_MOMENTARYs to MO() * Add changelog entry * Update docs/ChangeLog/20190830/PR5176.md Co-Authored-By: skullydazed <skullydazed@users.noreply.github.com>
* Language Keymap extras backport from ZSA fork (#6198)Drashna Jaelre2019-08-30
| | | | | | | | | | | | * Swedish extra keymap refactor * Fix swedish $ sign definition (#81) * Fix br abnt2 keymap compilation error * Add PR changelog doc * Update PR6198.md
* LUFA USB descriptor cleanup (#4871)fauxpark2019-08-30
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Fix indentation * Fix braces * Expand descriptor headers * Align descriptor elements * Nicer formatting * Tidy up preprocessor statements * Remove VERSION_BCD redefine - LUFA_VERSION_INTEGER is currently 0x170418 * Tidy up comments * Tweak ordering of HID report elements (no functional changes) * We don't need all of these newlines * Move default USB_MAX_POWER_CONSUMPTION closer to where it makes sense * Ask nicely * Add some more comments * Change indentation back to 4 spaces * Add changelog entry
* Added OLED Display autoscroll during periods of OLED data inactivity (#6546)XScorpion22019-08-25
| | | | | | | | * Added OLED Display autoscroll during periods of OLED data inactivity. * Fixing compile errors * Feedback from review
* Refactor `qmk compile-json` to `qmk compile` (#6592)skullydazed2019-08-25
|
* Add 'bootloadHID' flash target (#5587)Joel Challis2019-08-24
| | | | | | | | | | | | | | * Add 'bootloadHID' flash target * Prep for flash target * Add :flash support * Align bootloader wait messages Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update template to suggest use of :flash
* Add Zadig 101 to docs (#6585)fauxpark2019-08-23
| | | | | | | | | | | | | | | | | | * Add Zadig 101 to docs * Add USBasp bootloader name * Add links to the page * Note the usual VIDs and PIDs for the bootloaders * Add "List All Devices" note, just in case * Talk about keyboard-specific bootloader procedures * Send users to the new page in "Unknown Device for DFU Bootloader" section * Halfkay bootloaders are also an exception here
* Align flashing behaviour of dfu-util (#6578)Joel Challis2019-08-22
| | | | | | | | * Align flashing retry logic of dfu-util * Align bootloader wait messages Co-Authored-By: Drashna Jaelre <drashna@live.com>
* [Docs] Update how_keyboards_work.md (#6528)madivad2019-08-21
| | | | | | | | | | | | | | | | * Update how_keyboards_work.md bridged the gap between scancodes and keycodes, the doc didn't make the distinction and was ambiguous. * Update docs/how_keyboards_work.md Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update docs/how_keyboards_work.md fix typo Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
* Additional changes for Layer State typedef compatibility (#5906)Drashna Jaelre2019-08-21
| | | | | | | | | | | | | | | | * Additional changes for Layer State typedef compatibility * Replace biton32 with get_highest_layer in docs * Change additional layer structure code * Fix uGFX reference issue * Remove dynamic_keymap check * Where did all these extra spaces come from Co-Authored-By: fauxpark <fauxpark@gmail.com>
* Added keycodes for swapping and unswapping the Control and OS keys (#6110)Stephen Wanhella2019-08-21
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add MAGIC_SWAP_CONTROL_LGUI and MAGIC_UNSWAP_CONTROL_LGUI keycodes Key codes to swap and unswap the control and windows/cmd keys * Fix issues with pull request #6110 Renamed swap/unswap lctl and lgui key codes, added key codes to swap/unswap rctl and rgui, and moved new bool inside keycode_config.h struct to the end * Move new keycodes to the end of the enum (#6110) * add cases for swapped control and OS keys to mod_config (#6110) * Add new keycodes to feature_bootmagic.md (#6110) * Add R+L swap codes to keep in parity with AG_* codes * Extend Magic range check to include new magic codes * Update audio docs * Combine 2 byte ranges into 1 word for EECONFG Fix names for Keymap config EEPROM * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
* Remove superfluous JTAG disable code (#6445)fauxpark2019-08-20
| | | | | | | | | | | | | | | | | | * Remove superfluous JTAG disable code * 32A has differently named register * Accidentally some operators * 32A also has different JTAG pins * Wrap disable_jtag() in an ifndef * Document this new define * Rename the define, it conflicts with a LUFA thing Also, move the ifndef wrapping to the call in keyboard_setup()
* [Docs] Add RGB Matrix default mode define info (#6564)Drashna Jaelre2019-08-19
|
* Reword a note about the MANUFACTURER and PRODUCT defines in hardware_avr.md ↵fauxpark2019-08-17
| | | | (#6558)
* Add support for different encoder pinout for right half of split keyboard ↵Danny2019-08-16
| | | | | | | | (#6521) * Add support for different encoder pinouts for split keyboard * Update documentation for new encoder pinout feature
* Improve backlight PWM pin support (#6202)fauxpark2019-08-08
| | | | | | | | | | | | | | | | * Improve backlight PWM pin support * I accidentally an equals sign * Another typo * Order by pin number * Throw an error if backlight pin is C4 or C5 on 16/32U4 * Use else for clarity * Minor alignment adjustments
* Change "yu" to "you" in combo docs (#6510)Michael Clayton2019-08-08
|
* [Split] Add config option for DIRECT_PINS_RIGHT (#6479)Garrett Singer2019-08-03
| | | Adds support for different direct pin mappings on the halves of a split keyboard.
* [Docs] Add dfu-util and caterina udev examples (#6429)Joel Challis2019-08-01
|
* Fix typo for building Ergodox EZ keyboards (#6453)Rasmus Lindroth2019-07-31
|
* Update YouTube URLZachary J. Slater2019-07-29
| | | | The link was an outdated one to https://www.youtube.com/watch?v=7RH-1pAbjvw The correct link appears to be https://www.youtube.com/watch?v=tx54jkRC9ZY which is shortened as in the file.
* [Docs] Add Sections and MO(layer)/TG(layer) Example (#6308)thomas-d-112019-07-25
| | | | | | | | | | | | | | | * Add Sections and MO(layer)/TG(layer) Example Major changes: 1. Added sub-section headings to the portion before the examples. 2. Added a new Example 6, that allows MO(layer) and TG(layer) functionality to be embedded within tap dance functions. Minor Changes: 1. Edited some text to better fit with new sub-headings. * Update feature_tap_dance.md * Update feature_tap_dance.md
* Update IS_COMMAND definitions to use MOD_MASK_SHIFT (#6348)Konstantin Đorđević2019-07-20
| | | | | | | | | | | | * Update IS_COMMAND definition in templates to use MOD_MASK_SHIFT * Update IS_COMMAND in docs * Update IS_COMMAND default definition in tmk_core * Update table in Command docs based on suggestion Co-Authored-By: fauxpark <fauxpark@gmail.com>
* [Docs] Clarify Zadig usage in FAQ Docs (#6360)Drashna Jaelre2019-07-19
| | | | | | | | * Rewrite Zadig section to be more clear * Wordsmithing Co-Authored-By: MechMerlin <30334081+mechmerlin@users.noreply.github.com>
* Correct backlight on state docs (#6358)fauxpark2019-07-18
| | | | | | * Correct backlight on state docs * Reword to make it less confusing
* Extend maximum number of backlight levels to 31 (#6351)fauxpark2019-07-16
|
* Remove the need to specify NUM_OF_ENCODERS for the Encoder feature (#6328)Drashna Jaelre2019-07-16
| | | | | | | | | | | | * Remove the need to set NUM_OF_ENCODERS Instead, calculate the size of the array, and use that instead * Add hack for split common support * Remove NUM_OF_ENCODERS from keyboard config Can be reverted, if needed
* Allow Combo feature to be enabled/disabled live (#6318)Drashna Jaelre2019-07-16
| | | | | | | | | | | | | | * Add ability to enable/disable combos * Update documentation for Combo feature * Change keycodes for appeasement * Simplify combo_toggle function * Update names * Update combo docs to use tables
* Add ARM I2Cv1 support to i2c_master (#6262)Joel Challis2019-07-16
| | | | | | * Add ARM I2Cv1 support to i2c_master * Add I2Cv1 docs
* Make Caps Lock delay more reasonable (#6199)Drashna Jaelre2019-07-16
| | | | | | | | | | | | | | * Make Caps Lock delay more reasonable * Update documentation * Update docs/config_options.md Co-Authored-By: Konstantin Đorđević <vomindoraan@gmail.com> * Update docs/config_options.md Co-Authored-By: Konstantin Đorđević <vomindoraan@gmail.com>
* Configure Vagrant to use qmk_base_container (#6194)Joel Challis2019-07-16
| | | | | | | | | | * Initial conversion of vagrant to use qmkfm/base_container * Fix vagrant when using docker provider * Workaround for VirtualBox VM restarts * Generalise Vagrant docs slightly and add FAQ
* [Docs] Add dedicated page for Split Keyboard information (#5802)Drashna Jaelre2019-07-15
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * [Docs] Add dedicated page for Split Keyboard information * Apply suggestions from code review Co-Authored-By: drashna <drashna@live.com> * Fix Typos Co-Authored-By: drashna <drashna@live.com> * Fix some formatting issues * Add Additional RGB info * Fix Bulletted formatting * Apply suggestions from code review Co-Authored-By: drashna <drashna@live.com> * Fix line wrapping * Additional fixes and expansion * Reword warning/note Co-Authored-By: drashna <drashna@live.com> * add i2c/serial coexistance info * i2c markdown * Change i2c wiring text Co-Authored-By: drashna <drashna@live.com>
* Usbasploader bootloader option addition (#6304)yiancar2019-07-15
| | | | | | | | | | | | | | | | | | | | | | * Added USBasp bootloader option for USBasploader * author comment * ifdef fix :) * Add usbasp target * Update docs/flashing.md Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update docs/flashing.md Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update docs/flashing.md Co-Authored-By: fauxpark <fauxpark@gmail.com>
* QMK CLI and JSON keymap support (#6176)skullydazed2019-07-15
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Script to generate keymap.c from JSON file. * Support for keymap.json * Add a warning about the keymap.c getting overwritten. * Fix keymap generating * Install the python deps * Flesh out more of the python environment * Remove defunct json2keymap * Style everything with yapf * Polish up python support * Hide json keymap.c into the .build dir * Polish up qmk-compile-json * Make milc work with positional arguments * Fix a couple small things * Fix some errors and make the CLI more understandable * Make the qmk wrapper more robust * Add basic QMK Doctor * Clean up docstrings and flesh them out as needed * remove unused compile_firmware() function
* [Docs] Fix indented subheading on faq_debug.md (#6320)noroadsleft2019-07-13
|
* Documentation: Newbs Flashing: Hightlight that sudo may be needed (#6300)Phil Schalm2019-07-12
| | | | | | | | | | * Hightlight that sudo may be needed Also added "dfu-programmer: no device present" in so that anyone searching for that particular error can hopefully find the page. * Use new style of indicating a warning * Indicate that the FAQ should be read instead of blindly using sudo
* [Docs] Clarify the rules.mk setup for Unicode (#6286)fauxpark2019-07-11
| | | | | | | | | | | | | | | | | | | | | | | | * Clarify the rules.mk setup for Unicode * code point Co-Authored-By: Konstantin Đorđević <vomindoraan@gmail.com> * Remove "your" Co-Authored-By: Konstantin Đorđević <vomindoraan@gmail.com> * Undo a line change Co-Authored-By: Konstantin Đorđević <vomindoraan@gmail.com> * dot the comma Co-Authored-By: Konstantin Đorđević <vomindoraan@gmail.com> * Update docs/feature_unicode.md Co-Authored-By: Konstantin Đorđević <vomindoraan@gmail.com>
* Updated OLED Docs with notes about screen timeout. (#6276)XScorpion22019-07-08
| | | | | | | | * Updated OLED Docs with notes about screen timeout. * Update docs/feature_oled_driver.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
* Added mod carry over from press to release. (#5866)XScorpion22019-07-06
| | | | | Update docs/feature_space_cadet.md Co-Authored-By: fauxpark <fauxpark@gmail.com>
* fix typoshela2019-07-01
|
* [Docs] Reword confusing description of `TO(layer)` (#6174)lf2019-06-24
| | | | | | | | * Reword confusing description of `TO(layer)` * Update docs/keycodes.md Co-Authored-By: Drashna Jaelre <drashna@live.com>
* Fix breathing always on for soft PWM (#5983)fauxpark2019-06-19
| | | | | | | | | | * Fix breathing always on for soft PWM * Remove reference to hardware PWM pins in BACKLIGHT_BREATHING description Now, breathing will only be unsupported when Timers 1 and 3 are both used by Audio * Document BACKLIGHT_ON_STATE and its purpose
* Set default I2C clock speed to 100kHz for split_common (#6161)Danny2019-06-19
| | | | | | | | * Set default I2C clock rate for split_common boards to 100kHz Default from I2C driver is 400kHz. * Update documentation for setting I2C clock speed
* Fix backlight breathing on C6 (#6102)fauxpark2019-06-17
| | | | | | | | | | * Fix backlight breathing on C6 * Account for ATmega32A's single TIMSK register (MT40) * Document hardware PWM on D4 for ATmega32A * Add C6 and D4 to BACKLIGHT_PIN description