summaryrefslogtreecommitdiff
path: root/docs/feature_macros.md
Commit message (Collapse)AuthorAge
* Macro keycode name refactoring (#18958)Nick Brassel2022-11-05
|
* docs: some typos (#18582)George Rodrigues2022-10-05
| | | probably hacktoberism
* implement `tap_code16_delay` (#17748)JayceFayne2022-07-23
|
* Feature-ify Send String (#17275)Ryan2022-07-02
|
* [Docs] feature_macro.md: minor formatting fix (#16205)IskandarMa2022-02-05
|
* Fix keymap.json macro example (#15567)Tuk Bredsdorff2022-01-13
|
* [Docs] Note the order of enumerated custom keycodes (#15706)Albert Y2022-01-03
| | | Co-authored-by: filterpaper <filterpaper@localhost>
* Update feature_macros.md (#15026)Buttenup2021-12-27
| | | | | | | | | * Update feature_macros.md Added a link to the usage of SAFE_RANGE as this wasn't clear to me when I visited this page in isolation. * Fix typo Co-authored-by: Nick Brassel <nick@tzarc.org>
* Macros in JSON keymaps (#14374)Zach White2021-11-22
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * macros in json keymaps * add advanced macro support to json * add a note about escaping macro strings * add simple examples * format json * add support for language specific keymap extras * switch to dictionaries instead of inline text for macros * use SS_TAP on the innermost tap keycode * add the new macro format to the schema * document the macro limit * add the json keyword for syntax highlighting * fix format that vscode screwed up * Update feature_macros.md * add tests for macros * change ding to beep * add json support for SENDSTRING_BELL * update doc based on feedback from sigprof * document host_layout * remove unused var * improve carriage return handling * support tab characters as well * Update docs/feature_macros.md Co-authored-by: Nick Brassel <nick@tzarc.org> * escape backslash characters * format * flake8 * Update quantum/quantum_keycodes.h Co-authored-by: Nick Brassel <nick@tzarc.org>
* Basic keycode overhaul (#14726)Ryan2021-11-03
|
* [Docs] New section to modifier docs: Checking Modifier State (#10550)precondition2021-02-28
| | | | | | | | | | | | | | | | | | | | | | | | | | | | * Added new section to docs: Checking Modifier State * Added id anchors to all headers in modifiers docs * Added a Wikipedia link to bitwise operators and... crosslinked to the QMK macro docs. * Added an explanation on the format of mod bitmask * Added .md extension to hyperlinks to macros docs * Corrected mod mask order and changed notation * Documented add_oneshot_mods and del_oneshot_mods * Mentioned modifier checks in the macro docs * Explained strict modifier checking i.e. using `get_mods() & MOD_MASK == MOD_MASK` instead of simply `get_mods() & MOD_MASK` * Added (un)register_mods to the docs * Put left term of comparison in parens
* Add `tap_code_delay(code, delay)` (#11913)Ryan2021-02-17
| | | Co-authored-by: Drashna Jaelre <drashna@live.com>
* Remove unused `action_get_macro()` usages in user files (#11165)Ryan2021-01-11
|
* Typo fix: Useful function -> Useful Functions (#11342)Chas2020-12-30
| | | Thanks!
* Normalise include statements in core code (#11153)Ryan2020-12-11
| | | | | * Normalise include statements in core code * Missed one
* [Docs] Improve Unicode documentation (#8676)Konstantin Đorđević2020-06-20
|
* Add *OPT aliases for *ALT keycodes and macros (#8714)Konstantin Đorđević2020-04-12
|
* Add Post Processing to process_record (#4892)Drashna Jaelre2020-03-23
| | | | | | | | | | | | | | | | | | | * Improve process_record system Code based on @colinta's * Rename and better handle functions * Fix incorrect function call to process_record_user * Add documentation for post_process_record * Add both get_event_keycode and get_record_keycode functions And add some comments about these functions * Update code format * Cleanup merge artifacts
* Add support for delays in send_string. (#8244)Nick Brassel2020-02-27
|
* Add link to "Useful functions" in macro docs (#7446)Jez Cope2020-02-23
| | | | | | | | | | | | | * Add link to "Useful functions" in macro docs Help people find additional features they can activate within a macro * Update docs/feature_macros.md Co-Authored-By: Drashna Jaelre <drashna@live.com> Co-authored-by: skullydazed <skullydazed@users.noreply.github.com> Co-authored-by: Drashna Jaelre <drashna@live.com>
* Send string keycode tweaks (#7471)fauxpark2019-11-25
|
* [Docs] Update Super ALT↯TAB to remove use of unregister_code16 (#5766)Jez Cope2019-05-04
| | | | | The code as originally listed didn't work for me, but replacing `unregister_code16(LALT(KC_TAB));` with `unregister_code(KC_LALT);` fixes the problem and causes the macro to work as intended. Thanks to folks on Discord for helping me figure this out.
* [Docs] Adding Alt↯Tab example macro (#5616)roguepullrequest2019-04-14
|
* [Docs] Smallish overhaul of the docs (#5281)Drashna Jaelre2019-03-18
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Fix up Common functions doc * Add to extra commands to flashing doc * Rearrange and touch up Macros * Expand Newbs Flashing guide * Update process_record documentation * Add git to best practices name in sidebar * Expand FAQ for build/flashing * Add deprecated info to functions * Update docs/feature_macros.md Co-Authored-By: drashna <drashna@live.com> * Update docs/feature_macros.md Co-Authored-By: drashna <drashna@live.com> * Update docs/flashing.md Co-Authored-By: drashna <drashna@live.com> * Update docs/flashing.md Co-Authored-By: drashna <drashna@live.com> * Update docs/keymap.md Co-Authored-By: drashna <drashna@live.com> * Update docs/newbs_flashing.md Co-Authored-By: drashna <drashna@live.com> * Update docs/newbs_flashing.md Co-Authored-By: drashna <drashna@live.com> * Update docs/custom_quantum_functions.md Co-Authored-By: drashna <drashna@live.com> * Update docs/faq_build.md Co-Authored-By: drashna <drashna@live.com> * Update docs/feature_macros.md Co-Authored-By: drashna <drashna@live.com> * Update docs/keymap.md Co-Authored-By: drashna <drashna@live.com> * Fix up Common functions doc * Make pre-init example accurate * Update docs/custom_quantum_functions.md Co-Authored-By: drashna <drashna@live.com> * Zadig Driver catchall * Spelling Depriciated * Completely remove fn_actions section
* Replace instances of KEYMAP with LAYOUTnoroadsleft2019-02-21
| | | | | | Many instances in the QMK Docs referenced KEYMAP macros, which is outdated terminology. Replaced most instances of KEYMAP with LAYOUT, to reflect the desired usage.
* Fix up tap_code functionality (#4609)Drashna Jaelre2018-12-14
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add delay in Tap Code to avoid issues I think a few people have reporting issues with it working properly, and it may be a timing issue. The 'register_code' uses this sort of delay in some of the functions, and this is probably why. Adding the 100ms delay should hopefully fix any issues with it. * Make tap_code delay configurable * Update documentation * Bring tap_code16 inline with changes * Fix type for tap_code16 Bad copy-paste job * Just use the value check for the define * Clarify timing in docs Co-Authored-By: drashna <drashna@live.com> * Wordsmithing Co-Authored-By: drashna <drashna@live.com>
* Fix macro docs to be consistent with keyboard template (#4600)Drashna Jaelre2018-12-11
|
* Add tap_code function (#3784)Drashna Jaelre2018-10-01
| | | | | | | | | | * Add tap_code * formatting * Doc clarification * Rename variable to make more consistent
* Fix up info boxes.skullY2018-05-07
|
* Add SS_RALT for AltGR usage in macrosDrashna Jael're2018-03-09
|
* Update feature_macros.md (#2387)Mitchell van Manen2018-03-01
| | | break statements are never reached due to the return statement, so unnecessary
* Trim trailing whitespacefauxpark2017-12-09
|
* Fix some of the more obvious typosfauxpark2017-12-09
|
* Convert all headings to Title Casefauxpark2017-12-09
|
* added SS_LSFT to featured macrosGilbert Consellado2017-11-20
|
* add example keymapBalz Guenat2017-11-16
|
* extend macro docs a bitBalz Guenat2017-11-16
|
* Restructure the hardware and feature docs to make things easier to find (#1888)skullydazed2017-10-24
* fix #1313 by documenting more config.h options * Clean up and organize documentation