aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fee0b18f..11dab989 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -504,6 +504,7 @@ if ENABLE_TEST
noinst_PROGRAMS = \
test/run_decoder \
+ test/run_encoder \
test/software_volume
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -521,6 +522,14 @@ test_run_decoder_SOURCES = test/run_decoder.c \
$(INPUT_SRC) \
$(DECODER_SRC)
+test_run_encoder_SOURCES = test/run_encoder.c \
+ src/conf.c src/buffer2array.c \
+ src/utils.c \
+ src/audio_parser.c \
+ $(ENCODER_SRC)
+test_run_encoder_LDADD = $(MPD_LIBS) \
+ $(ENCODER_LIBS)
+
test_software_volume_SOURCES = test/software_volume.c \
src/audio_parser.c \
src/pcm_volume.c