summaryrefslogtreecommitdiff
path: root/libavcodec/ra288.c
Commit message (Collapse)AuthorAge
...
* misc spelling/wording/grammar fixesDiego Biurrun2008-09-11
| | | | Originally committed as revision 15296 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Convert table to integer.Vitor Sessak2008-09-10
| | | | Originally committed as revision 15292 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Avoid duplicating compute_lpc_coefs() function in both the RA288 and AAC ↵Vitor Sessak2008-09-04
| | | | | | decoders. Originally committed as revision 15193 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Check *data_size in decode_frame()Vitor Sessak2008-08-06
| | | | Originally committed as revision 14636 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: alignmentVitor Sessak2008-08-06
| | | | Originally committed as revision 14635 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Flip (by making buf[i] -> buf[size-i-1]) two buffers: {sp,gain}_block. ThisVitor Sessak2008-08-06
| | | | | | needs duplicating a few loops, but now the code is clearer. Originally committed as revision 14634 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename prodsum() function to convolve()Vitor Sessak2008-08-05
| | | | Originally committed as revision 14615 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Modify all codecs to report their supported input and output sample format(s).Peter Ross2008-07-31
| | | | Originally committed as revision 14482 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Do not declare a counter as unsigned when it is not neededVitor Sessak2008-07-29
| | | | Originally committed as revision 14469 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: rename loop counter vars to i,jVitor Sessak2008-07-29
| | | | Originally committed as revision 14468 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: new lineVitor Sessak2008-07-28
| | | | Originally committed as revision 14457 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove the now useless phase variable from contextVitor Sessak2008-07-28
| | | | Originally committed as revision 14456 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: make comment match var nameVitor Sessak2008-07-28
| | | | Originally committed as revision 14454 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: align commentsVitor Sessak2008-07-28
| | | | Originally committed as revision 14453 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename two context vars: s/sb/sp_block/, s/lhist/gain_block/Vitor Sessak2008-07-28
| | | | Originally committed as revision 14452 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Declare temporary buffers to be only of the necessary sizeVitor Sessak2008-07-28
| | | | Originally committed as revision 14451 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove redundant commentsVitor Sessak2008-07-28
| | | | Originally committed as revision 14450 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: do not align with now removed next instructionVitor Sessak2008-07-28
| | | | Originally committed as revision 14449 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: remove braces and useless newlineVitor Sessak2008-07-28
| | | | Originally committed as revision 14448 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change the way the input is passed to do_hybrid_filter(). Before, in[0] wasVitor Sessak2008-07-28
| | | | | | | the oldest input sample passed and in[n-1] was the latest. Now it is the contrary. This allows making backward_filter() somewhat simpler. Originally committed as revision 14447 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove RA288Context.output buffer. This buffer is just RA288Context.sbVitor Sessak2008-07-28
| | | | | | | | backwards (output[i] == sb[N-i], where N is the buffer length). This makes the code slower, this will be fixed in my next commit. Originally committed as revision 14446 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add a few comments pointing to the G.728 specificationVitor Sessak2008-07-27
| | | | Originally committed as revision 14444 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove the history buffer from the context. It can easily be evaluatedVitor Sessak2008-07-27
| | | | | | from the lhist buffer. Originally committed as revision 14443 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename two context buffers: pr{1,2} -> {sp,gain}_lpc. Also add a few doxyVitor Sessak2008-07-27
| | | | | | comments. Originally committed as revision 14437 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove st1 and st2 temporary buffers in backward_filter() and use insteadVitor Sessak2008-07-27
| | | | | | | | RA288Context.pr{1,2}. Note that the pr{1,2} buffers are one unity smaller than the st{1,2} buffers. My guess is that the original coder decided to add one to the array sizes "just to be sure". Originally committed as revision 14435 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change slightly the meaning of RA288Context.phase. ThisVitor Sessak2008-07-27
| | | | | | | allows to remove two intermediary buffers and avoid a few memcpy's. Originally committed as revision 14432 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove st1 and st2 variables from context, since they could be just local varsVitor Sessak2008-07-26
| | | | Originally committed as revision 14421 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename st{1,2}{a,b} context variables to more meaningful names: ↵Vitor Sessak2008-07-26
| | | | | | {sp,gain}_{rec,hist} Originally committed as revision 14420 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: remove useless parenthesisVitor Sessak2008-07-26
| | | | Originally committed as revision 14418 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move colmult() function to the beginning of file to group DSP-related functions.Vitor Sessak2008-07-26
| | | | Originally committed as revision 14417 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove an useless comment describing colmult()Vitor Sessak2008-07-26
| | | | Originally committed as revision 14416 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove an useless comment describing prodsum()Vitor Sessak2008-07-26
| | | | Originally committed as revision 14415 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Give the context variables of ra288 a better name: s/glob/ractx/Vitor Sessak2008-07-26
| | | | Originally committed as revision 14414 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Give the context structure of ra288 a better name: ↵Vitor Sessak2008-07-26
| | | | | | s/Real288_internal/RA288Context/ Originally committed as revision 14413 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: grammar nitsVitor Sessak2008-07-24
| | | | Originally committed as revision 14368 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename update() function to backward_filter() and add a doxy commentVitor Sessak2008-07-24
| | | | Originally committed as revision 14364 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename and comment bandwidth broadening tablesVitor Sessak2008-07-24
| | | | | | (s/table1a/syn_bw_tab/, s/table2a/gain_bw_tab/). Originally committed as revision 14363 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Follow FFmpeg convention of returning negative values on error in ↵Vitor Sessak2008-07-24
| | | | | | eval_lpc_coeffs() Originally committed as revision 14362 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename pred() to eval_lpc_coeffs() and add a doxy commentVitor Sessak2008-07-24
| | | | Originally committed as revision 14361 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Give windowing tables a more descriptive nameVitor Sessak2008-07-24
| | | | | | (s/table1/syn_window/, s/table2/gain_window/). Originally committed as revision 14360 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add comments to do_hybrid_window()Vitor Sessak2008-07-24
| | | | Originally committed as revision 14359 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Give parameters of do_hybrid_window() more meaningful namesVitor Sessak2008-07-24
| | | | Originally committed as revision 14358 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename co() function to the much more descriptive name ofVitor Sessak2008-07-24
| | | | | | do_hybrid_window(). Also change a misleading and wrong comment. Originally committed as revision 14357 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify co(): write constant in a more readable wayVitor Sessak2008-07-24
| | | | Originally committed as revision 14356 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify co(), use memcpy/memmove and colmult() when useful.Vitor Sessak2008-07-24
| | | | Originally committed as revision 14355 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: alignmentVitor Sessak2008-07-19
| | | | Originally committed as revision 14304 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify co(): do not abuse pointer aritmeticsVitor Sessak2008-07-19
| | | | Originally committed as revision 14303 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify co(): remove variables that are only used onceVitor Sessak2008-07-19
| | | | Originally committed as revision 14301 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify: do not overuse pointer aritmeticVitor Sessak2008-07-17
| | | | Originally committed as revision 14271 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Declare parameters of pred() that could be const as suchVitor Sessak2008-07-17
| | | | Originally committed as revision 14270 to svn://svn.ffmpeg.org/ffmpeg/trunk