summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in18
1 files changed, 11 insertions, 7 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index eee68c61..9d43bc83 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -874,13 +874,17 @@ CCTK_CXX_ATTRIBUTE_UNUSED
CCTK_C_ATTRIBUTE_ALIGNED
CCTK_CXX_ATTRIBUTE_ALIGNED
-## Find out whether the C compiler supports __attribute__((cold))
-#CCTK_C_ATTRIBUTE_COLD
-#CCTK_CXX_ATTRIBUTE_COLD
-#
-## Find out whether the C compiler supports __attribute__((hot))
-#CCTK_C_ATTRIBUTE_HOT
-#CCTK_CXX_ATTRIBUTE_HOT
+# Find out whether the C compiler supports __attribute__((cold))
+CCTK_C_ATTRIBUTE_COLD
+CCTK_CXX_ATTRIBUTE_COLD
+
+# Find out whether the C compiler supports __attribute__((hot))
+CCTK_C_ATTRIBUTE_HOT
+CCTK_CXX_ATTRIBUTE_HOT
+
+# Find out whether the C compiler supports __builtin_expect
+CCTK_C_BUILTIN_EXPECT
+CCTK_CXX_BUILTIN_EXPECT
CCTK_FORTRAN_REAL4
CCTK_FORTRAN_REAL8