summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2006-07-25 20:02:24 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2006-07-25 20:02:24 +0000
commitd37fe298527cf86cfec4be254a66c3338567abed (patch)
tree1874b39d2e7ff58b1f092e2b161312bf2dd5f73e /lib/make/configure.in
parentd71c093565ef17c099e2b3d83ad2c679f1c3e17c (diff)
Set the F77 compiler and flags from the F90 compiler and flags earlier
during configuring. This way they are set before they are used to determine the properties of the Fortran compiler. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4355 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in21
1 files changed, 9 insertions, 12 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 9af917fb..7fc96872 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -337,6 +337,15 @@ AC_SUBST(F90_PROFILE_FLAGS)
##########################################################################
+# Deal with the Fortran compiler issues.
+# If there's a Fortran 90 compiler use that for all the Fortran.
+if test "x$F90" != "x" -a "x$F90" != "xnone" -a "x$KNOWN_F77" = "x" ; then
+ F77=$F90
+ F77FLAGS=$F90FLAGS
+ F77_DEBUG_FLAGS=$F90_DEBUG_FLAGS
+ F77_OPTIMISE_FLAGS=$F90_OPTIMISE_FLAGS
+ F77_WARN_FLAGS=$F90_WARN_FLAGS
+fi
# The known architecture stuff has probably set the LIBS variable
# So remember what it is and set it to blank to prevent any problems with the
@@ -1027,18 +1036,6 @@ AC_DEFINE_UNQUOTED(CCTK_CACHELINE_BYTES, $CACHELINE_BYTES)
AC_DEFINE_UNQUOTED(CCTK_CACHE_SIZE, $CACHE_SIZE)
-# Deal with the Fortran compiler issues.
-# If there's a Fortran 90 compiler use that for all the Fortran.
-if test "x$F90" != 'x' -a "x$F90" != 'xnone' -a "x$F77" != 'xnone' ; then
- F77=$F90
- F77FLAGS=$F90FLAGS
- F77_DEBUG_FLAGS=$F90_DEBUG_FLAGS
- F77_OPTIMISE_FLAGS=$F90_OPTIMISE_FLAGS
- F77_PROFILE_FLAGS=$F90_PROFILE_FLAGS
- F77_WARN_FLAGS=$F90_WARN_FLAGS
-fi
-
-
#########################################################################
#Check for extra stuff
#########################################################################