summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-09-26 00:21:00 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-09-26 00:21:00 +0000
commita1492b067055e73d5b61dfe45c3cd4200bee64a2 (patch)
treef0677049f29bd0d18f50337523989fc8a1c563ac /lib/make/configure.in
parent06d94fb1dae1bedc506b432ccb1157d6aaa874d8 (diff)
Introduce macros CCTK_DECLARE and CCTK_DECLARE_INIT which declare or
declare and initialise local variables. They also add the necessary magic to prevent compiler warnings about unused variables. If the compiler supports __attribute__((unused)), then use this. Otherwise, use the existing fallback of taking the variable's address. In Fortran, use the variable's kind as fallback. Use these macros in autogenerated code and in "cctk.h". git-svn-id: http://svn.cactuscode.org/flesh/trunk@4146 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 8c39c6e8..4eedc758 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -535,6 +535,11 @@ CCTK_CHECK_CXX_RESTRICT
CCTK_C_BOOL
CCTK_CXX_BOOL
+# Find out whether the C compiler supports __attribute__((unused))
+CCTK_C_ATTRIBUTE_UNUSED
+CCTK_CXX_ATTRIBUTE_UNUSED
+
+
dnl Do we have crypt(3)
CCTK_CHECK_FUNC(crypt, , CCTK_CHECK_LIB_FUNC(crypt, crypt))