summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorgoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2007-10-18 02:25:44 +0000
committergoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2007-10-18 02:25:44 +0000
commit95ce88d27a9b486bccd5362bd93955e4c58f46a7 (patch)
treed306b4efddc96572b83761719636285c34a8e7ff /lib/make/configure.in
parent1660a05da4e525664ed19707e32763b78022a70f (diff)
Move setting of F90 and F77 to none earlier to prevent a bug
when neither compiler has been found which left types undefined. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4433 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in22
1 files changed, 12 insertions, 10 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 71a06286..9f818190 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -354,6 +354,18 @@ if test "x$F90" != "x" -a "x$F90" != "xnone" -a "x$F77" = "x" ; then
F77_PROFILE_FLAGS=$F90_PROFILE_FLAGS
fi
+# Set default Fortran compilers
+AC_SUBST(F90)
+if test -z "$F90" ; then
+ F90='none'
+fi
+
+AC_SUBST(F77)
+if test -z "$F77" ; then
+ F77='none'
+fi
+
+
# The known architecture stuff has probably set the LIBS variable
# So remember what it is and set it to blank to prevent any problems with the
# rest of the configure stuff.
@@ -1111,16 +1123,6 @@ dnl Run any other scripts necessary
AC_OUTPUT_COMMANDS(,$PERL -s $PERL_CONFIGURE_SCRIPT -compiler_f77="$F77" -opts_f77="$F77FLAGS" -compiler_f90="$F90" -opts_f90="$F90FLAGS" .)
-# Set default Fortran compilers
-AC_SUBST(F90)
-if test -z "$F90" ; then
- F90='none'
-fi
-AC_SUBST(F77)
-if test -z "$F77" ; then
- F77='none'
-fi
-
dnl Output everything
CCTK_FinishFiles
AC_OUTPUT(make.config.defn make.config.deps make.config.rules)