summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorjthorn <jthorn@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-02-10 14:36:39 +0000
committerjthorn <jthorn@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-02-10 14:36:39 +0000
commit50d91252462a1c4ea29ed598cc3597166cdc6c05 (patch)
tree8fb4a4f6648da0e88e362b163a62ea5df76c36de /lib/make/configure.in
parent2539079735f781e7548b098bb1a1b13dab853826 (diff)
[[from Jonathan && Thomas R jointly]]
catch the error case where ~/.cactus/config (or another options file) contains (eg) OPTIMISE=no # UK spelling with "S" but the user says gmake blah-config OPTIMIZE=yes # US spelling with "Z" or more generally, where (after combining settings from all options file(s) and the command line) we have an inconsistent mixture of OPTIMISE and OPTIMIZE settings before this commit, this would produce a no-optimization configuration with this commit, it produces an optimized configuration git-svn-id: http://svn.cactuscode.org/flesh/trunk@3986 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index e8feb0a6..949c0e65 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -43,7 +43,11 @@ OPTIMISE_MODE='yes'
if test -n "$OPTIMISE" ; then
changequote({, })
OPTIMISE=`echo $OPTIMISE | tr '[:upper:]' '[:lower:]'`
+ OPTIMIZE=`echo $OPTIMIZE | tr '[:upper:]' '[:lower:]'`
changequote([, ])
+ if test "$OPTIMISE" != "$OPTIMIZE" ; then
+ AC_ERROR(OPTIMISE=\"$OPTIMISE\" is inconsistent with OPTIMIZE=\"$OPTIMIZE\"!)
+ fi
if test "$OPTIMISE" != 'yes' -a "$OPTIMISE" != 'no' ; then
AC_ERROR(Didn't recognize setting of OPTIMISE=\"$OPTIMISE\" (should be either \"yes\" or \"no\"))
fi